installTitle not working in StatusMessage?

Topics: Archive - General
Dec 30, 2014 at 12:46 PM
Show-InstallationProgress -StatusMessage 'Uninstalling application [$installTitle]. Please Wait...'

above line should had shown me thi

Variables: Application

[string]$appVendor = 'Igor Pavlov'
[string]$appName = '7-Zip'
[string]$appVersion = '9.35 beta'
[string]$installTitle = "$appVendor $appName $appVersion"

but i getting the this:

'Uninstalling application [$installTitle]. Please Wait...'

What wrong with the string since it doesnt show this:

'Uninstalling application Igor Parlov 7-Zip 9.35 Beta. Please Wait...'
Dec 30, 2014 at 12:55 PM
Edited Dec 30, 2014 at 12:55 PM
I put '' around the [$installTitle] and got this error
Error Inner Exception(s):
-------------------------

Message        : Cannot convert value "Igor Pavlov 7-Zip 9.35 beta" to type "System.Int32". Error: "Input string was not in a correct format."
InnerException : System.FormatException: Input string was not in a correct format.
                    at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberForma
                 tInfo info, Boolean parseDecimal)
                    at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
                    at System.ComponentModel.Int32Converter.FromString(String value, NumberFormatInfo formatInfo)
                    at System.ComponentModel.BaseNumberConverter.ConvertFrom(ITypeDescriptorContext context, CultureInf
                 o culture, Object value)
how to fix this Error?
Dec 30, 2014 at 1:24 PM
this is working fine?

Show-InstallationProgress -StatusMessage $installTitle

so how do i combine this with normal text?
Dec 30, 2014 at 1:27 PM
ok found out

this is working:

Show-InstallationProgress -StatusMessage "Uninstalling application $installTitle. Please Wait..."
Marked as answer by Always on 12/30/2014 at 6:27 AM