Error 1603/1722 by registering an application

Topics: Archive - General
May 3, 2014 at 1:27 PM
Dear all,

I use the tool since two month and it works fine for me.

Currently I have to use the tool for a new installation. On the end I get the error code 1603, into eventvwr I saw the error 1722 on the last step of installation to register the program.exe

I tried different ways to install the application...

When I start the installation within a new script (not the tool) using "$errno=Start-Process -FilePath "Setup.exe" -Wait -Passthru).ExitCode" all works fine, no error. Also when I run the install manually with the setup.exe, no error occured.

The same command line used within the Deploy-Application.ps1 the error occured.

So it seams the problem only occure when I use the tool.

Strange...

Regards,
Maximilian
Coordinator
May 5, 2014 at 1:43 PM
Hi Maximilian,

Have you tried using the Execute-Process function? 1603 as an exit code would seem to imply this is actually an MSI being called by the executable. You might consider running the MSI directly using Execute-MSI which will give verbose logging of the MSI. You can look through this to find out what's causing the 1603. It might be a custom action which is failing due to something you're doing in the script.

Mind posting more details on the script itself and what you're trying to install?

Dan