CloseApps: Specify process/executable _plus_ version

Topics: Archive - General
Mar 19, 2014 at 9:01 AM
I've got an issue with the "CloseApps" parameter:
We've got CAD workstations with several versions of a CAD software installed (e.g. NX8, NX8.5, NX9). If I have to install a hotfix for one of them I need to make sure that the respective version isn't running. As all versions have the same process name ("ugraf") I can't use
Show-InstallationWelcome -CloseApps "ugraf"
as this would close all processes disregarding the version.
Is there a solution for this issue?