execute-msi error

Topics: Archive - General
Feb 12, 2014 at 7:30 AM
Hi, great tool.

I only run into one problem.
I want to install an msi, when i run it manually it installs without any problems, here's the command line:
msiexec /i "%~dp0agnc.msi" ADDLOCAL=Net_Client,VPN_Client,LPE DESKTOP_SHORTCUT="" FIREWALL_STATE=off CERT_DEFAULT_USE="1" CONFIG_FILE="config.xml" SUPPRESS_PROGRAM_UPDATES=1 REBOOT=ReallySuppress /qn

Now, when i use the deploy.ps1 i do it like this:
Execute-MSI -Action install -Path "agnc.msi" '"ADDLOCAL=Net_Client,VPN_Client,LPE DESKTOP_SHORTCUT="" FIREWALL_STATE=off CERT_DEFAULT_USE="1" CONFIG_FILE="config.xml" SUPPRESS_PROGRAM_UPDATES=1"'

But then this error appears in the log file:

[12-02-2014 07:40:02] [Pre-Installation] Spinning up Progress Dialog in a separate thread with message: [Installing ATT Remote Client 9.4.0.3004. Please wait...]
[12-02-2014 07:40:03] [Pre-Installation] Executing [msiexec.exe /i "C:\LocalData\Example_ATT Remote Client Install 9.4.0.3004 ENU\Files\agnc.msi" TRANSFORMS=""ADDLOCAL=Net_Client,VPN_Client,LPE DESKTOP_SHORTCUT="" FIREWALL_STATE=off CERT_DEFAULT_USE="1" CONFIG_FILE="config.xml" SUPPRESS_PROGRAM_UPDATES=1"" REBOOT=ReallySuppress /QN /L*v "C:\Windows\Logs\Software\agnc_Install.log"]...
[12-02-2014 07:40:03] [Pre-Installation] Working Directory is [C:\LocalData\Example_ATT Remote Client Install 9.4.0.3004 ENU\Files]
[12-02-2014 07:40:03] [Pre-Installation] Execution failed with code: 1639
[12-02-2014 07:40:03] [Pre-Installation] ATT_RemoteClientInstall_9.4.0.3004_ENU_01 Installation completed with exit code [1639].

Why is the TRANSFORM option added to the command?
Anyone can point me in the right direction?
Feb 12, 2014 at 3:00 PM
I've found it!!
This is the correct format:

Execute-MSI -Action install -Path "agnc.msi" -Parameters 'ADDLOCAL=Net_Client,VPN_Client,LPE DESKTOP_SHORTCUT="" FIREWALL_STATE=off CERT_DEFAULT_USE="1" CONFIG_FILE="config.xml" SUPPRESS_PROGRAM_UPDATES=1 REBOOT=ReallySuppress /qn'
Marked as answer by Patres14 on 2/12/2014 at 7:00 AM