Executing Deploy-Application.EXE - nothing happens, need help

Topics: Archive - Deployment Scripts, Archive - General
Mar 9, 2015 at 4:39 PM
Edited Mar 9, 2015 at 4:39 PM
Is it possible to debug why this happens ?

Log file taken from one of my failing computers
<![LOG[[Initialization] :: *******************************************************************************]LOG]!><time="16:21:53.99960" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: *******************************************************************************]LOG]!><time="16:21:53.99960" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: [Mcafee_Agent_4.8.0.1500_x86x64_EN_01] setup started.]LOG]!><time="16:21:54.17060" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Script [C:\Windows\ccmcache\t\AppDeployToolkit\AppDeployToolkitExtensions.ps1] dot-source invoked by [C:\Windows\ccmcache\t\AppDeployToolkit\AppDeployToolkitMain.ps1]]LOG]!><time="16:21:54.18660" date="03-09-2015" component="" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Script [C:\Windows\ccmcache\t\AppDeployToolkit\AppDeployToolkitExtensions.ps1] dot-source invoked by [C:\Windows\ccmcache\t\AppDeployToolkit\AppDeployToolkitMain.ps1]]LOG]!><time="16:21:54.18660" date="03-09-2015" component="PSAppDeployToolkitExt" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: [Mcafee_Agent_4.8.0.1500_x86x64_EN_01] script version is [1.0.0]]LOG]!><time="16:21:54.20160" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: [Deploy Application] script version is [3.5.0]]LOG]!><time="16:21:54.21760" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: [App Deploy Toolkit Main] script version is [3.5.0]]LOG]!><time="16:21:54.21760" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: [App Deploy Toolkit Extensions] version is [1.5.0]]LOG]!><time="16:21:54.21760" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Computer Name is [PC045184.aas.its.nja.dk]]LOG]!><time="16:21:54.23360" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Current User is [AASNT\admgf2e]]LOG]!><time="16:21:54.23360" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: OS Version is [Microsoft Windows 7 Professional Service Pack 1 64-bit 6.1.7601.65536]]LOG]!><time="16:21:54.23360" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: OS Type is [Workstation]]LOG]!><time="16:21:54.24860" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Current Culture is [da-DK] and UI language is [DA]]LOG]!><time="16:21:54.26460" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Hardware Platform is [Physical]]LOG]!><time="16:21:54.42060" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: PowerShell Host is [ConsoleHost] with version [4.0]]LOG]!><time="16:21:54.43560" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: PowerShell Version is [4.0 x64]]LOG]!><time="16:21:54.43560" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: PowerShell CLR (.NET) version is [4.0.30319.34209]]LOG]!><time="16:21:54.45160" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: *******************************************************************************]LOG]!><time="16:21:54.45160" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Return fully qualified registry key path [Registry::HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontDPI]]LOG]!><time="16:21:54.49860" date="03-09-2015" component="Convert-RegistryPath" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Get registry key [Registry::HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontDPI]]LOG]!><time="16:21:54.49860" date="03-09-2015" component="Get-RegistryKey" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Deployment type is [Installation]]LOG]!><time="16:21:54.52960" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
<![LOG[[Initialization] :: Script [C:\Windows\ccmcache\t\AppDeployToolkit\AppDeployToolkitMain.ps1] dot-source invoked by [C:\Windows\ccmcache\t\Deploy-Application.ps1]]LOG]!><time="16:21:54.52960" date="03-09-2015" component="PSAppDeployToolkit" context="" type="1" thread="1" file="">
Best Regards
Anders Jensen
Mar 11, 2015 at 11:16 PM
Hi Anders,

I use PowerGUI Script editor to edit the ps1 file. It has debug feature. When you want to test the script you can do it click on Debug + Start Debugging). If everything is fine, you should get Message that you need to run the script with Administrator privilege. Also with the editor it is easy for you to check your syntax and parameters such as {} etc.

Hope this help.

PshellFan