This project is read-only.

Multiple Parameters in the Execute-Process function?

Topics: Archive - Deployment Scripts
Jan 8, 2015 at 4:55 PM
Hi all,

I love the idea of the PADT, but I run into an issue:

I want to use the Execute-Process function to call a command like

regedit.exe /s "C:\Users\FirstName Last Name\AppData\local\Temp\HKCU.reg"

with a space in the second path parameter. I already tried different syntax of the command but was not able to get it working. Unfortunately you documentation for release 3.5 contains only a simple example

-Parameters '/s'

for this function.

Is there a way to get this working (it should because you have the -Parameters option for this function) and if yes, how looks the syntax for the example above?

If not I guess I want to report this bug which will hopefully fixed quickly by you ;)

Thank you!
Jan 23, 2015 at 2:59 PM
Looks like we are running into the same issue in my environment. I've calling multiple installation switches from a variable for the -Parameters option. When performing this silently through an SCCM 2007 client, it appears to not execute properly. Ultimately, my application will hang and program will fail once it meets the allotted runtime.
Jan 27, 2015 at 11:40 AM
Edited Jan 27, 2015 at 11:42 AM
Hi LoganDS,

the answer was given by the dev guys. You have to use a special syntax:

Click here