This project is read-only.

.Net Framework 3.5 requirement for Windows 8.1 with toolkit version 3.5.0

Topics: Archive - General
Dec 4, 2014 at 7:10 PM
When starting the toolkit with Deploy-Application.exe, the add Windows feature prompt comes up asking to install the .Net Framework 3.5 with Windows 8.1. This does not occur when running the powershell script directly or under version 3.2.0 of the toolkit.

I didn't see the requirement listed in the documentation for it, so I wanted to check to see if this needs to be added.
Dec 5, 2014 at 7:20 AM
Can you download the latest version of the Deploy-Application.exe from the latest beta code under the "Source Code" tab of this site and see if it resolves your issue? The target .NET version for the exe should be .NET 2.0.
Dec 5, 2014 at 2:05 PM
I just downloaded the latest beta version, used a fresh install of Windows 8.1, and received the same message.

If the target .NET version is 2.0, then I guess this is the expected behavior. The Windows feature that tries to install is ".NET Framework 3.5 (includes .NET 2.0 and 3.0)."
Dec 5, 2014 at 2:18 PM
Well the exe should be able to target 2.0 and higher...what version of .NET do you have installed?
Dec 5, 2014 at 2:37 PM
Edited Dec 5, 2014 at 2:38 PM
I used a fresh install, so Windows 8/8.1 comes with .NET 4.5. To run .NET 2.0 and 3.5 applications, it needs to be installed. I believe this is inline with Server 2012/2012 R2 as well.
Dec 5, 2014 at 3:26 PM
Does it work fine if you create an "app.config" file in the same directory as Deploy-Application.exe with the below text?
<?xml version="1.0" encoding="utf-8" ?>
    <supportedRuntime version="v4.0"/>
    <supportedRuntime version="v2.0.50727"/>
Dec 5, 2014 at 3:46 PM
That worked. Using the file name app.config didn't change anything, but renaming it to deploy-application.exe.config didn't show any .NET prompts and ran the toolkit like normal.

Great job!
Jan 9, 2015 at 7:41 PM
I had the same problem. The solution to put a file named deploy-application.exe.config with the above text in the directory with Application-Deploy.exe worked great!