Installing phase does not run in the script on one machine on 4

Topics: Archive - Deployment Scripts
Oct 17, 2014 at 8:45 AM
Edited Oct 17, 2014 at 8:56 AM
Version 3.1.0 AppDeployToolkitMain
OS : Microsoft Windows 7 Entreprise 64 bits 6.1.7601
Powershell : 2.0 or 3.0 x64
Mode : NonInteractive

Installing phase does not run in the script on one machine on 4

The installation phase is not visible in the log file :
Example KO :
[16-10-2014 23:00:22] [Initialization] Uninstall_MsftVisio_AllVersion_R01_X86_SN_P_MU setup started.
[16-10-2014 23:00:22] [Initialization] Script [C:\Windows\ccmcache\5b\AppDeployToolkit\AppDeployToolkitExtensions.ps1] dot-source invoked by [C:\Windows\ccmcache\5b\AppDeployToolkit\AppDeployToolkitMain.ps1]
[16-10-2014 23:00:22] [Initialization] Script [C:\Windows\ccmcache\5b\AppDeployToolkit\AppDeployToolkitMain.ps1] dot-source invoked by [C:\Windows\ccmcache\5b\Deploy-Application.ps1]
[16-10-2014 23:00:22] [Initialization] Uninstall_MsftVisio_AllVersion_R01_X86_SN_P_MU script version is [1.0.0]
[16-10-2014 23:00:22] [Initialization] Deploy Application script version is [3.1.0]
[16-10-2014 23:00:22] [Initialization] App Deploy Toolkit Main script version is [3.1.1]
[16-10-2014 23:00:22] [Initialization] App Deploy Toolkit Extensions version is [1.0.0]
[16-10-2014 23:00:22] [Initialization] PowerShell version is [3.0 x64]
[16-10-2014 23:00:22] [Initialization] PowerShell host is [ConsoleHost version 3.0]
[16-10-2014 23:00:22] [Initialization] OS version is [Microsoft Windows 7 Entreprise 64 bits 6.1.7601]
[16-10-2014 23:00:23] [Initialization] Hardware platform is [Physical]
[16-10-2014 23:00:23] [Initialization] Computer name is [XXXXXXX]
[16-10-2014 23:00:23] [Initialization] Current user is [CIB\XXXXXXX$]
[16-10-2014 23:00:23] [Initialization] Current Culture is [fr-FR] and UI language is [FR]
[16-10-2014 23:00:23] [Initialization] Deployment type is [Installation]
[16-10-2014 23:00:23] [Initialization] Running under Session 0.
[16-10-2014 23:00:23] [Initialization] Installation is running in [NonInteractive] mode.
[16-10-2014 23:00:24] [Post-Installation] Uninstall_MsftVisio_AllVersion_R01_X86_SN_P_MU Installation completed with exit code [0].
[16-10-2014 23:00:24] [Post-Installation] ----------------------------------------------------------------------------------------------------------

=> KO : Installation Phase is not present in the file log

Example OK :
[16-10-2014 23:00:31] [Initialization] Uninstall_MsftVisio_AllVersion_R01_X86_SN_P_MU setup started.
[16-10-2014 23:00:32] [Initialization] Script [C:\Windows\ccmcache\6x\AppDeployToolkit\AppDeployToolkitExtensions.ps1] dot-source invoked by [C:\Windows\ccmcache\6x\AppDeployToolkit\AppDeployToolkitMain.ps1]
[16-10-2014 23:00:32] [Initialization] Script [C:\Windows\ccmcache\6x\AppDeployToolkit\AppDeployToolkitMain.ps1] dot-source invoked by [C:\Windows\ccmcache\6x\Deploy-Application.ps1]
[16-10-2014 23:00:32] [Initialization] Uninstall_MsftVisio_AllVersion_R01_X86_SN_P_MU script version is [1.0.0]
[16-10-2014 23:00:32] [Initialization] Deploy Application script version is [3.1.0]
[16-10-2014 23:00:32] [Initialization] App Deploy Toolkit Main script version is [3.1.1]
[16-10-2014 23:00:32] [Initialization] App Deploy Toolkit Extensions version is [1.0.0]
[16-10-2014 23:00:32] [Initialization] PowerShell version is [3.0 x64]
[16-10-2014 23:00:32] [Initialization] PowerShell host is [ConsoleHost version 3.0]
[16-10-2014 23:00:32] [Initialization] OS version is [Microsoft Windows 7 Entreprise 64 bits 6.1.7601]
[16-10-2014 23:00:33] [Initialization] Hardware platform is [Physical]
[16-10-2014 23:00:33] [Initialization] Computer name is [XXXXXX]
[16-10-2014 23:00:33] [Initialization] Current user is [CIB\XXXXXXXX$]
[16-10-2014 23:00:33] [Initialization] Current Culture is [fr-FR] and UI language is [FR]
[16-10-2014 23:00:33] [Initialization] Deployment type is [Installation]
[16-10-2014 23:00:34] [Initialization] Running under Session 0.
[16-10-2014 23:00:34] [Initialization] Installation is running in [NonInteractive] mode.
[16-10-2014 23:00:34] [Installation] Microsoft Visio Premium 2010 Installed in A/R Programs
[16-10-2014 23:00:34] [Installation] UninstallString SubKey Installed
[16-10-2014 23:00:34] [Installation] Value = HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Office14.VISIO
[16-10-2014 23:00:34] [Installation] UninstallString Value Full
[16-10-2014 23:00:34] [Installation] Value = "C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller\setup.exe" /uninstall VISIO /dll OSETUP.DLL
[16-10-2014 23:00:34] [Installation] File Setup.exe Installed in "C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller"
[16-10-2014 23:00:34] [Installation] Run Uninstall Microsoft Visio Premium 2010 Mode Silent
[16-10-2014 23:00:34] [Installation] Command Run = "C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller\setup.exe" /uninstall Visio /config "C:\Windows\ccmcache\6x\Files\Uninstall\VisioPremium2010\UninstallVisioSilent.xml"
[16-10-2014 23:03:58] [Installation] Return Code Uninstall : Success = 0

=> OK : Installation Phase is present in the file log

Thank you in advance for your help
Fabrice ( French )
Marked as answer by Fab78 on 10/17/2014 at 1:56 AM
Oct 17, 2014 at 9:04 AM
the error comes from my script !
indeed it does not execute anything in the installation phase.
sorry for this post
thank you
Fabrice