This project is read-only.

MSI properties - Execute-MSI -Action Install -Path

Topics: Archive - Deployment Scripts
Sep 1, 2014 at 3:59 PM

I need to specify some msi properties via command line in the deploy-application.ps1 and Im having some issues with the syntax:

Execute-MSI -Action Install -Path "%application1.msi" -Parameters "LicenseKey=xxxxxxxx" LicenseTo=xxxxxxxx" "servername=xxxxxx" /qn

The above command-line successfully deploys and configures via command prompt and SCCM, when configuring in deploy-application.ps1 the syntax is incorrect.

Can someone please confirm the correct syntax for executing an msi with properties please?

Sep 1, 2014 at 4:43 PM
Edited Sep 1, 2014 at 4:43 PM
Execute-MSI -Action Install -Path "%application1.msi" -Parameters "LicenseKey=xxxxxxxx LicenseTo=xxxxxxxx servername=xxxxxx /qn"
Sep 2, 2014 at 8:10 AM

Thanks Ive already tried that command line, when executing the the command the windows installer box is appearing with install options. Its appears the command line syntax is incorrect!

Sep 2, 2014 at 1:58 PM
Thanks Shaun,

I have resolved my issue with the below command line:

Execute-MSI -Action Install -Path "APPLICATION1.msi" -Parameters 'LICENSEKEY="xxxx" LICENSETO="xxxx" SERVERNAME="xxxx" /QN'

It seems I had " and ' in the incorrect order

Thanks again for your help!
Marked as answer by Toffeenose81 on 9/2/2014 at 5:58 AM