Bold App Title

Topics: Archive - General
Jul 24, 2014 at 3:16 PM
I am trying to bold the app name display at the initial prompt, because it is not easily seen. I know at line 2871 in AppDeployToolKitMain.ps1 is the call that displays the English WelcomeMessage and App Title. I've already added an additional "'n" to bring it down another line which helps. How do I go about doing this. I know in adding this to the form:

[code]
$LabelAppName.Font = "Arial, 10pt ,style=Bold"
[/code]

makes the whole string bold, I just want the app name bold. Any ideas?
Jul 24, 2014 at 4:18 PM
I was able to get it to work. I had to create a new text object and separate the messages...if interested I can share
Aug 1, 2014 at 12:43 PM
Hi Richard,

Can you share the code please ?

Many Thanks.
Aug 8, 2014 at 1:21 PM
Edited Aug 8, 2014 at 1:26 PM
This is what it looks like:
Google Image
Image

I added a bold switch to the main form. To get it to look like this, you will have to modify the AppDeployToolkitMain.ps1 in the AppDeployToolkit Folder .

I added a few lines of actual code here to give you an idea of where to add it, but the line number should be accurate
right below line 29:
[string] $Message = $null,
__[string] $BoldMessage = $null,__
Then add after 481:
Param (
    $Title = $installTitle,
    $Message = $null,
        __$BoldMessage = $null,__
Then add this whole section after line 630:
# Label Bold Text
$labelBoldText.DataBindings.DefaultDataSourceUpdateMode = 0
$labelBoldText.Name = "labelBoldText"
$System_Drawing_Size = New-Object System.Drawing.Size
$System_Drawing_Size.Height = 148
$System_Drawing_Size.Width = 385
$labelBoldText.Size = $System_Drawing_Size
$System_Drawing_Point = New-Object System.Drawing.Point
$System_Drawing_Point.X = 25
$System_Drawing_Point.Y = 50
$labelBoldText.Location = $System_Drawing_Point
$labelBoldText.Margin = "0,0,0,0"
$labelBoldText.Padding = $labelPadding
$labelBoldText.TabIndex = 1
$labelBoldText.Font = "Microsoft Sans Serif, 10pt, style=Bold"
$labelBoldText.Text = $Boldmessage
$labelBoldText.TextAlign = "MiddleLeft"
$labelBoldText.Anchor = "Top"
$labelBoldText.add_Click($handler_labelBoldText_Click)
Then after line 696
$formInstallationPrompt.Controls.Add($labelText)
__$formInstallationPrompt.Controls.Add($labelBoldText)__
To trigger these parameters you have to change line 499; add $BoldMessage rogth before $Message
If ($deployModeNonInteractive -eq $true) {
    Write-Log "Bypassing Installation Prompt [Mode: $deployMode]... __$BoldMessage__ $Message"
    Return
}
Or you can download this file: AppDeployToolkitMain.ps1
Aug 8, 2014 at 1:31 PM
Edited Aug 8, 2014 at 1:31 PM
I noticed the codeplex doesn't "bold" my areas I specify when I compose a message it puts a "__" before and after. Don't add that to the ps1 file, just the text. sorry