This project is read-only.

show installationwelcome - just closes programs..

Topics: Archive - General
Apr 29, 2014 at 2:18 PM
Hi

I've used 'show-installationwelcome' before without problems but this time I am experiencing a few.. or 1 really :-)

When The deployment starts I've configured it to show the inst. welcome and prompt user to close IE, firefox & chrome..
but it just closes them without the prompt..

This is a script exerpt:

    # Show Welcome Message, close Internet Explorer if required, allow up to 3 deferrals, verify there is enough disk space to complete the install and persist the prompt
    Show-InstallationWelcome -CloseApps "iexplore,chrome,firefox" -AllowDefer -DeferTimes 3 -CheckDiskSpace -PersistPrompt -BlockExecution

    # Show Progress Message (with the default message)
    #Show-InstallationProgress

    Remove-MSIApplications "Java 7"
    
    
#*===============================================
#* INSTALLATION 
$installPhase = "Installation"
#*===============================================

    # Perform installation tasks here

    Execute-MSI -Action Install -Path "jre1.7.0_55.msi" -Transform "jre1.7.0_55.mst" /QN
log says:

[29-04-2014 15:14:08] [Pre-Installation] Checking for running applications [iexplore,chrome,firefox]...
[29-04-2014 15:14:08] [Pre-Installation] The following processes are running: []
[29-04-2014 15:14:08] [Pre-Installation] Resolving process descriptions...
[29-04-2014 15:14:08] [Pre-Installation] Finished checking running applications.
[29-04-2014 15:14:08] [Pre-Installation] Force closing application(s) [Internet Explorer] without prompting user...
[29-04-2014 15:14:10] [Pre-Installation] Block Execution Parameter specified.
[29-04-2014 15:14:10] [Pre-Installation] Bypassing Block-AppExecution Function [Mode: NonInteractive]
[29-04-2014 15:14:10] [Pre-Installation] Getting information for installed Application Name [Java 7]...
[29-04-2014 15:14:11] [Pre-Installation] Found installed application [Java 7 Update 25] version [7.0.250] matching application name [Java 7]
[29-04-2014 15:14:11] [Pre-Installation] Removing Application [Java 7 Update 25 ]...


Ideas?
Coordinator
Apr 29, 2014 at 2:46 PM
It's running in Non-Interactive mode. We force close the processes automatically if this is the case.

Cheers, Dan
Apr 29, 2014 at 2:47 PM
Edited Apr 29, 2014 at 2:47 PM
Is your deployment set at Interactive or NonInteractive under the Param?
[string] $DeployMode = "Interactive",
If I understand this correctly, it should be Interactive otherwise it will close without prompting.

Edit: Looks like Dan beat me to it ;)
Apr 29, 2014 at 2:57 PM
Hi

I've also been looking at interactive vs. non-interactive..

In sccm the commandline was: "Deploy-Application.EXE"

and nothing else..

I've now added:

"Deploy-Application.EXE" -DeploymentType "Install" - DeployMode "Interactive"

Just to be sure..

But I am now facing another issue...
as soon as it downloads the deployment script and starts installation...before it does ANYTHING .. it gives me an error 0x87****324
as if it thinks it's finished but cannot detect the installed software.. which is rather obvious since it hasn't installed anything..
the error occurs before it even prompts me to close IE etc..
Apr 29, 2014 at 2:58 PM
I don't even get a log :-(
Coordinator
Apr 29, 2014 at 3:03 PM
Hey,

Okay so you're probably installing as SYSTEM instead of the user, which will automatically kick it back into NonInteractive mode. Just "Deploy-Application.exe Install" or "Deploy-Application.exe Uninstall" should suffice in SCCM.

Now, if you really want to run as SYSTEM but still display the UI, you'll need to use a trick - it's outlined in this thread: https://psappdeploytoolkit.codeplex.com/discussions/465270

Hope this helps, Dan.
Apr 29, 2014 at 3:10 PM
Hi Dan

How can I run as user when installation requires admin rights?

none of our users have local admin rights.. :-)
Coordinator
Apr 29, 2014 at 3:11 PM
Using the method outlined in the thread listed above, you will use the SYSTEM account to kick off the install as the user which has been given elevated rights by the SYSTEM account. :)
Apr 30, 2014 at 8:44 AM
Right..
So what I've just done is:

set the installation command to:

"Deploy-Application.EXE" -DeploymentType "Install" -DeployMode "interactive"

Running in system account..

It still just runs in non-interactive... IF I am logged in as non-local admin
if I log in as administrator (domain admin) then the prompt is displayed..

I've used the exact same script setup etc. before and it didn't just close apps etc.. so I don't understand what's changed...
Coordinator
Apr 30, 2014 at 11:56 AM
Hey, sorry I think you missed the other thread where you'd need to invoke Deploy-Application using ServiceUI.exe. Running Deploy-Application.exe directly under the System account will always run non-interactive.

Could you verify something for me? Run as System, only when a user is logged in, and tick Allow User to Interact (or something to that effect, I don't have SCCM handy here right now). I'll try look into this later too myself.

Dan
May 1, 2014 at 7:18 AM
Hi Dan..

Perfect.. I tried the servuceui, and it works...

1 thing some users did was:

They got the popup asking them to close IE & Chrome...
Instead of clicking on "close programs" they just clicked "Continue" .. and java proceeded to install but never closed IE nor Chrome..
which resulted in the plugin not being installed correctly to their browsers...

and ideas here?
Coordinator
May 1, 2014 at 3:17 PM
Can you pull up a log of one of these installs where clicking Continue just bypassed the check?
May 5, 2014 at 10:57 AM
Hi

I'm not sure what went wrong.. but I can't find anything in the logs.. it never lists any applications open.

No many were affected so I'll chalk it up to a user error of some sort..


bottom line.. ServuceUI.exe works a beaut!