Unable to show welcome message when deplpoying via SCCM 2012

Topics: Archive - General
Oct 8, 2013 at 4:24 AM
Edited Oct 8, 2013 at 6:03 AM
Hi Guys,

Quite new to this and also SCCM 2012. I have modified the PS1 file and have run it manually using both ps1 and exe file and I get the prompts etc to shut down the application and everything works.

However in SCCM I create an application which runs the deploy-application.exe -deploymenttype "install" in the installation command field and when I deploy it, the application installs but no pop ups for user interaction. I even selected install when users are logged in so that I can check the allow user interaction function. Still no go. What am I doing wrong with my sccm application when running this? Note that users do not have admin rights... we just want the interactive session to work in sccm so that users have the option to save their work and shutdown the required apps before installation takes place.

Thanks,
Coordinator
Oct 8, 2013 at 1:16 PM
Can you pull up the log for a successful deployment? It sounds like the install is running under Session 0 (running as SYSTEM) and is switching to NonInteractive mode to prevent any issues with dialogs appearing during the deployment - as it's not possible to display dialogs under Session 0.

I've not tested running as administrator while allowing user interaction, but I would assume this swaps out of Session 0 somehow. We can investigate though.

For comparison, my users have admin rights so Run As User works perfectly for me.
Oct 8, 2013 at 3:10 PM
Cthia,

Make sure that in your deployment that the Installation Program Visibility option under the User Interface tab is not set to "Hidden". That will block any user interaction from the deployment at all.

Image
Oct 8, 2013 at 10:24 PM
Thanks for the reply guys.

Sintaxasn - I too have the feeling it is because it is running under Session 0. I actualy saw it in the admin guide and so put a switch to deploymode "Interactive", however still no go. Which logs would you like? or from SCCM or from the PS install?

DarkTempest - I also initially thought it was that.... I even have it selected as maximised but no go on that either. Not sure if it will make a difference if I change it from Maximised to Normal but will give it a go. I notice yours also states whether or not a user is logged on and I have that option as well. Does it work for you? and does your users have admin rights?

I am thinking that it may not be possible for an interactive session to run under system installs... It's a pity as this is a great script and we would really like to use it.
Oct 8, 2013 at 11:00 PM
Edited Oct 8, 2013 at 11:02 PM
Hi Guys,

Just an update here. I tried a different method of deploying which is to use packages rather than applications in SCCM 2012. By using packages there is an option to select to select program can only run when user is logged in. This then gives you the option to select the run mode which I chose Run with Administrative Rights and then I am able to tick the box, allow users to view and interact with the program.

This works! But ideally, I would like to use the application deployment as it has a lot of other features such as app detection etc... I do not know why they don't just have the same option in Application as they do with packages.

If anyone has any idea's how to deploy an application with administrative rights that would be great...

Cheers!
Oct 9, 2013 at 1:02 AM
Cthia,

It does work for me. I choose whether or not the user is logged in and it will install in session 0 when no one is there, and present dialogs and notifications when someone is logged in.

When you deploy the application to a workstation (vs a user), that installation is supposed to occur under the SYSTEM account. The only time that it runs under the user context is when the application is deployed to a user collection.
Coordinator
Oct 9, 2013 at 4:59 PM
darktempest, thanks for confirming this behavior. So to clarify, you get dialogs and notifications even when running as SYSTEM, if a user is logged in, is that correct? This should be the case.

Cthia, open up the App Deploy Toolkit log for the specific install. By default it should be written to C:\Windows\Logs\Software but this can be changed. We're specifically checking to see if there's any mention of non-interactive mode and why it might be set.

Cheers, Dan
Oct 9, 2013 at 9:51 PM
Good Morning All,

Thanks for all the help. DarkTempest, I was unable to get it working with the configuration you showed and I think it is because we deploy it to users. I much prefer deploying to computers but they want it deployed to user collections instead.

I did however finally got it to work by changing it to install only when users are logged in, ticking the allow users to interact with the install. In addition I had to manually set the deploymode to Interactive. It works like a charm now but by deploying to a user collection we don't have the option to install when the user is not logged in. It would be great if SCCM could deploy on boot when deployed to computers like group policy. But with the help of this script, deploying applications to user collections is brilliant.

Have to thank the creators of this script, allows us to standardise all installs. Great job guys!! When I roll out another application based on computers, I will see if your setting works.

Thanks again everyone.
Oct 14, 2013 at 7:09 AM
Guys another question, anyway of allowing more then 30 mins before apps close down? Seems like if I set anything more then 1800, the install does not work...
Oct 14, 2013 at 10:10 PM
Hi Guys, I figured out why the time wasn't working! I just forgot to resign the PS script. I had a look at the xml file and I am trying to figure out this line. Does anyone know what the number 4140000 is in multiples of? Doesn't equal seconds.. I basically want to change this to make sure I can allow for a timeout of 5 hours..

<InstallationUI_Timeout>4140000</InstallationUI_Timeout> <!-- Time in seconds to automatically timeout installation dialogs. Default is 1 hour and 55 minutes so that dialogs timeout before SCCM times out. -->

Thanks again.
Aug 26, 2014 at 4:18 AM
Edited Aug 26, 2014 at 4:18 AM
Hi Guys, Has anyone been able to deploy applications to a user collection/ application catalog. It fails in Windows 7 and above computers.

I can successfully deploy the same application to a computer collection(using Software Center) as it uses the LOCAL SYSTEM account as opposed to the logged in user account. What is the best way to deploy applications to user based collections using the application catalog.

Thanks,
Mahesh
Coordinator
Sep 1, 2014 at 7:59 PM
Not sure that is a toolkit question? I'd suggest posting to MS ConfigMgr forums.
Sep 2, 2014 at 3:19 PM
yea not really a toolkit question, application catalog is more like a self service type installer. Users go to it to get software. The catalog is a web interface for that. Software Center is still 'deploying' the software.